Services remain stable and uninterrupted at this time. Our engineers are actively monitoring the environment to ensure everything continues to operate smoothly.
We appreciate your continued patience and support. If you have any questions, our support team is available via Live Chat or support@liquidweb.com.
Posted Apr 13, 2025 - 02:00 EDT
Update
We will be extending the maintenance window with an additional hour and 15 minutes (until 1am EST) due to unforeseen circumstances. There may be some intermittent disruption of services during this time for brief periods. We will provide updates as necessary.
Posted Apr 12, 2025 - 23:44 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 12, 2025 - 22:00 EDT
Scheduled
Liquid Web Systems and Network Engineers will be performing emergency maintenance on a distribution router supporting a subset of services in our DC3 data center. There is an expected network service interruption of between thirty and sixty minutes during the window. Engineers will be on-site and engaged throughout, and will work to limit the interruption as much as possible. Customers with affected services will see a further notification in their customer portal.
Our support team is on standby if you need any help or have questions or concerns. You can connect with us through the following channels: