Acronis Backups not being displayed in portal
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted May 13, 2021 - 22:47 CDT
Monitoring
A fix has been implemented. We are currently monitoring the results.
Posted May 13, 2021 - 11:24 CDT
Investigating
We've been alerted to an issue that's impacting Acronis Backup information appearing correctly within the portal. We're currently working with our 3rd party vendor to resolve this issue as quickly as possible. We apologize for any inconvenience that this may cause.

We will update this post once additional information is available. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 13, 2021 - 09:08 CDT