Premium Business Email - Webmail Access Issues

Incident Report for Liquid Web - Services

Monitoring

Our email vendor has implemented a fix for the Premium Business Email webmail access issue, and service access is being restored. We are currently monitoring the situation to ensure stability.

Email delivery continues to function normally. We will provide further updates if needed.

If you have any questions, please contact our support team via LiveChat or by submitting a case.
Posted Dec 29, 2025 - 14:38 EST

Investigating

We are currently experiencing issues with accessing the Premium Business Email webmail interface. We are actively working with our email provider to resolve this as quickly as possible.

Please note that email delivery is not currently affected. We will continue to post updates here as more information becomes available.

If you have any questions, please contact our support team via LiveChat or by submitting a case.
Posted Dec 29, 2025 - 12:35 EST
This incident affects: Business Email.