The affected servers are back online and operating normally. This incident has been resolved.
Posted Sep 23, 2026 - 13:38 EDT
Monitoring
Our Data Center Operations team identified the issue and immediately replaced the PSU. The affected servers are now back online and operating normally.
We are continuing to monitor the environment closely to ensure stability.
If you are still experiencing any issues, please reach out to us via Support Chat or by opening a support case, and our team will be happy to assist you.
Posted Sep 23, 2026 - 10:39 EDT
Investigating
We are currently experiencing a service disruption affecting some servers in our Lansing DC due to a rack outage. Our engineering team is actively working to resolve the issue as quickly as possible.
We appreciate your patience as our engineers work to restore full service. If you have any further questions or concerns, please contact us at support@liquidweb.com or via Live Chat.