Premium Business Email Webmail Issues
Incident Report for Liquid Web - Services
Resolved
The Incident is now closed and the hosted email system is operating as normal.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 11, 2021 - 07:33 CDT
Identified
We are actively working with our email vendor towards a full resolution of Webmail issues. A small sub-set of users may continue to encounter intermittent error prompts at this time. More updates will be provided as they become available.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 06, 2021 - 14:45 CDT
This incident affected: Business Email.