Acronis, our 3rd party vendor, has alerted us that Acronis Cyber Protect Cloud in the USA (US5) data center is fully functional now, all services are up and running. We will continue to monitor for any further updates.
If you have any questions, please do not hesitate to contact a member of our support team via live chat or ticket.
Posted Dec 02, 2024 - 11:12 EST
Update
We are continuing to investigate this issue.
Posted Dec 02, 2024 - 10:15 EST
Investigating
Acronis, our 3rd party vendor, has alerted us of an issue as with the Acronis Backup Cloud datacenter being degraded. The Acronis Cloud team is working on the issue resolution.
Service impact: Some customers might be unable to reach Acronis Web Restore, Acronis Backup Gateway and Acronis Cyber Protection Console.
We sincerely appreciate your understanding and patience as we resolve this issue. Thank you for your continued support.