Cloud Block and Object Storage Services Degraded
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 22, 2025 - 11:30 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2025 - 01:17 EST
Investigating
Our teams are currently investigating an issue causing cloud block and object storage service disruptions. We will update this status post as more information becomes available.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jan 22, 2025 - 00:21 EST