Phone System Issues

Incident Report for Liquid Web - Services

Monitoring

The issue has been resolved and phone services have been fully restored. Our team will continue to monitor system performance.
Posted Jan 12, 2026 - 17:56 EST

Investigating

We are investigating an issue preventing customers from reaching support via Phone.

Please use Live Chat or open a Support Case at my.liquidweb.com for immediate assistance while we restore the phone service.

We appreciate your patience and understanding as we work to restore this service. Thank you.
Posted Jan 12, 2026 - 17:43 EST
This incident affects: Support Services (Phone).