Business Email Authentication Failures
Incident Report for Liquid Web - Services
Resolved
The team is currently running a maintenance task to ensure the issue will not recur but advised all authentication has been fully restored at this time. We apologize for the inconvenience.
Posted Sep 26, 2019 - 23:38 CDT
Investigating
At this time we are investigating reports of authentication failures impacting some Premium Business Email boxes. We are working with our provider to get this resolved as quickly as possible and will provide additional information as soon as it becomes available.

In the meantime, if you have any questions please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Sep 26, 2019 - 22:10 CDT
This incident affected: Business Email.