Investigating issues with Object Storage

Incident Report for Liquid Web - Services

Resolved

At this time our engineer team is working on investigating issues with our Object Storage System which has led some reports of customer seeing degraded performance. Our Engineering team is engaged and actively investigating and working to address the issue
Posted Nov 26, 2023 - 12:00 EST