Support Request Delays

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved. If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Oct 27, 2022 - 16:50 EDT

Monitoring

Our teams have implemented a fix and contact with our support teams is functioning as expected again. We are currently monitoring to ensure no recurrence.
Posted Oct 27, 2022 - 10:28 EDT

Investigating

Our teams are currently investigating an issue causing delays for Support responses and phone connectivity. We will update this status post as soon as more information becomes available.

If you have any questions or concerns, please contact a member of our support team via live-chat or ticket (support@liquidweb.com).
Posted Oct 27, 2022 - 09:53 EDT