Thank you for your time and patience. Our engineers have successfully replaced the switch and recovered the server access. We are closely monitoring the situation now.
If you have any questions or concerns, please don't hesitate to contact us via Live Chat or by opening a case.
Posted Feb 24, 2026 - 05:15 EST
Identified
Our team is currently working on replacing the faulty switch. We will keep this space updated as soon as the work is completed.
Posted Feb 24, 2026 - 04:30 EST
Investigating
A possible switch failure has been reported at our DC3 location. Our networking team is currently investigating and will provide an update once more information has been gathered.
Some customers in this location may experience an outage. Please contact Support if you have any questions or notice any anomalies.
Posted Feb 24, 2026 - 04:23 EST
This incident affected: Network (LAN Network) and Data Centers (DC3 - LAN).