Premium Business Email Control panel issue
Incident Report for Liquid Web - Services
Resolved
A solution has been put in place by our email venders engineering team. Issue preventing admins from accessing the admin control panel has been resolved!

We appreciate your patience in the matter, and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 20, 2024 - 03:53 EDT
Identified
This outage results from a recent update by cybersecurity firm CrowdStrike, which has caused widespread disruptions for various industries worldwide, including airlines, banks, media outlets, technology companies, telecom firms, and businesses of all sizes. CrowdStrike has communicated that they are in the process of rolling back the update that caused this issue. Our email vendor is working to resolve this issue as quickly as possible.

We appreciate your patience in the matter, and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 19, 2024 - 09:36 EDT
Investigating
We have identified an issue with the Premium business email control panel access. We are engaging with our email vendor to resolve the issue.

This may be affecting the ability to manage the emails via the control panel.

We appreciate your patience in the matter, and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 19, 2024 - 05:25 EDT
This incident affected: Business Email.