Cart Issues
Incident Report for Liquid Web - Services
Resolved
This issue is now resolved. Our cart is functioning as expected at this time.
Posted Oct 17, 2024 - 10:22 EDT
Investigating
We are currently investigating issues with items failing to be removed from the cart. We will update this status post as soon as we have additional information.

We sincerely appreciate your understanding and patience as we resolve this issue. Thank you for your continued support.

Our teams are here to help you. Please do not hesitate to get help via live-chat, ticket or by toll-free phone at 1.855.348.9060 or internationally at +1.517.322.0434.
Posted Oct 17, 2024 - 09:15 EDT