Partial Outage With Upstream SSL Provider
Incident Report for Liquid Web - Services
Resolved
We have not seen any issues with the SSL provider for some time and believe that this has been resolved.
Posted 2 months ago. Aug 13, 2019 - 01:55 CDT
Monitoring
Our upstream provider indicates the issue is resolved, and our testing shows SSL orders are now completing as expected. We will continue to monitor the situation to ensure it is definitively resolved.
Posted 2 months ago. Aug 12, 2019 - 23:58 CDT
Update
We are continuing to investigate this issue.
Posted 2 months ago. Aug 12, 2019 - 23:38 CDT
Investigating
Our SSL provider is experiencing issues which are causing new SSL orders and renewals to fail. They have been notified, are aware of the situation, and are working diligently to resolve it. Existing SSL certificates will continue to function as expected. We will post updates here as they become available.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted 2 months ago. Aug 12, 2019 - 23:34 CDT
This incident affected: Managed WordPress, Managed WooCommerce, and Management Portal.