Acronis Portal Performance Degraded
Incident Report for Liquid Web - Services
Resolved
At this time the Acronis portal is back up fully functional. We will continue to monitor it for any further issues.
Posted May 26, 2021 - 16:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 23, 2021 - 06:21 EDT
Investigating
We've been alerted to an issue that's impacting performance while attempting to access the Acronis Backup Portal. We're currently investigating to resolve this issue as quickly as possible. We apologize for any inconvenience that this may cause.
Posted May 23, 2021 - 04:54 EDT