Intermittent network outage to Lansing datacenter

Incident Report for Liquid Web - Services

Resolved

Network functionality has returned to normal. This incident has been resolved.
Posted Mar 22, 2025 - 00:21 EDT

Monitoring

Our Engineers have made adjustments to bring the affected portion of the network back online. We will continue to monitor the network for stability.
Posted Mar 22, 2025 - 00:15 EDT

Investigating

Our Engineers are currently investigating an intermittent network outage that is impacting our Lansing datacenter. We will provide updates as more information comes to light.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Mar 21, 2025 - 21:07 EDT
This incident affected: Network (LAN Network) and Data Centers (DC3 - LAN).