Premium Business Email Issue
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Jul 06, 2021 - 12:36 CDT
Identified
Engineers are continuing to work towards a full resolution of this issue.
Posted Jun 30, 2021 - 19:38 CDT
Investigating
Webmail Errors:

We are actively working with our email vendor towards a full resolution, a small sub-set of users may continue to encounter intermittent error prompts at this time. More updates will be provided as they become available.
Posted Jun 30, 2021 - 16:29 CDT
This incident affected: Business Email.