Billing system experiencing issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Feb 21, 2022 - 17:06 CST
Update
Our portal is in maintenance mode at this time. Teams are continuing to work to resolve this issue.
Posted Feb 21, 2022 - 16:00 CST
Identified
We have identified the cause of this issue. Our teams are currently working towards resolution. We will update this status post again as soon as more information is available.
Posted Feb 21, 2022 - 08:56 CST
Investigating
Hello,

We are currently seeing issues with our billing system and are working on a fix presently. Please watch for further updates as they occur.
Posted Feb 21, 2022 - 07:50 CST
This incident affected: Managed WordPress, Managed WooCommerce, Cloud Dedicated, Cloud VPS Hosting, API, Management Portal, and MWP / MWCH Management Portal.