Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 01, 2023 - 21:01 CDT
Scheduled
Liquid Web Network Engineers will be performing hardware maintenance on a subset of network switches within our Lansing, Michigan Data Center. Customer servers that require these switches will experience an interruption of service during the window. You may subscribe to further updates for this maintenance above.
We appreciate your patience as our Engineering teams work to maintain the stability of our platform. If you have any further questions or concerns, please feel free to reach out to us via live-chat in your customer portal (https://my.liquidweb.com/), ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Mar 27, 2023 - 16:56 CDT
This scheduled maintenance affected: Network (LAN Network), Cloud Dedicated, and Data Centers (DC3 - LAN).