Issues logging in to Email Help Tool at https://help.emailsrvr.com/
Incident Report for Liquid Web - Services
Resolved
This issue is resolved.
Posted May 24, 2023 - 11:51 EDT
Update
Our email vendor team and their engineers are still actively working on this issue. We will provide an update as soon as we have more information.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 23, 2023 - 12:58 EDT
Investigating
We have seen increased reports of users not being able to access the Email Help Tool at https://help.emailsrvr.com/. Logging in will show a server error. This issue seems to be affecting the Help Tool only.

We have reached out to our email Engineers to look into this issue and will provide an update when we have more information.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 19, 2023 - 15:41 EDT
This incident affected: Business Email.