Business Email - Hosted Exchange Disruption
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 08, 2020 - 08:37 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 08, 2020 - 08:36 EST
Identified
At this time we are experiencing a disruption with an isolated cluster of Hosted Exchange mailboxes. The impacted mailboxes are unavailable, however, we are working with our vendor to get the issue resolved as quickly as possible. Additional info will be provided as soon as it becomes available.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (855) 348-9060.
Posted Jan 08, 2020 - 07:01 EST
This incident affected: Business Email.