Liquid Web Websites Degraded Service
Incident Report for Liquid Web - Services
Resolved
Our teams have resolved this issue. Our websites are now functioning as expected.

If you have any questions, please contact a member of our support team via live-chat and ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 22, 2020 - 09:18 CDT
Identified
The issue has been identified and our teams are currently working to resolve.
Posted Oct 22, 2020 - 09:08 CDT
Investigating
We are currently investigating reports of Liquid Web websites having degraded service in some areas. We will update this post with additional information.

If you have any questions, please contact a member of our support team via live-chat and ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Oct 22, 2020 - 08:29 CDT