Cloud Sites Inbound Phone Number Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Oct 23, 2019 - 11:01 EDT
Monitoring
We are continuing to monitor performance on our inbound voice lines. Should you experience any issues dialing a team directly, you can always reach our support team at 800-580-4985.
Posted Oct 22, 2019 - 23:57 EDT
Identified
The issue has been identified and the 1(855)348-9060 number is now functional to call. We are still investigating a few other lines in but the direct line mentioned above and our standard Liquid Web phone line are available to be used.
Posted Oct 22, 2019 - 17:21 EDT
Investigating
We are currently experiencing issues with the direct inbound Cloud Sites Support phone number 1(855)348-9060. Our teams are working to identify and resolve the issue.

In the meantime, please call us at our main LiquidWeb line 1(800)580-4985, then 2 for Support, and 3 for Cloud Sites.
Posted Oct 22, 2019 - 10:54 EDT
This incident affected: Support Services (Phone Support).