Emails Blocked by Yahoo
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Mar 27, 2023 - 08:34 EDT
Monitoring
Our email vendor has been partnering with the affected recipient mail hosts and their internal reporting has shown significant improvements in deliverability, however, they are continuing to work towards full remediation of this issue.

While measures are being taken to prevent any impact to users, some may experience mail delivery delays or delivery failures. Impacted users are encouraged to retry their messages or advise their recipients to safelist their domain.
Posted Mar 23, 2023 - 08:14 EDT
Identified
We have seen an increase in customer complaints with Yahoo blocking or deferring emails going out from Business Email mailboxes. We are working with our email vendor on this and they have assured us they are working right now directly with Yahoo to fix this situation.

We are currently waiting for them to remove this block for us. We do not have any workarounds right now for this situation and email Engineers are fully engaged with this issue. We will provide updates as we have them.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 16, 2023 - 14:29 EDT
This incident affected: Business Email.