Premium Business Email Control Panel Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 29, 2020 - 17:31 EST
Investigating
Our vendor reported an issue with some functions inside the Admin Control Panel. Examples - provisioning actions like creating mailboxes or changing passwords and portal navigation errors. We will continue to work with them and stay current on the situation and will update this status page with details as we have them.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (855) 348-9060.
Posted Jan 29, 2020 - 15:30 EST
This incident affected: Business Email.