Business Email Control Panel Issues
Incident Report for Liquid Web - Services
Resolved
This has been resolved.
Posted Mar 05, 2024 - 10:39 EST
Identified
Our email vendor has identified issues with the Email control panel. Panel. Admins might be met with a loading error message and bad gateway error.

Our vendor team is working on this issues at this time. We will provide updates as we have them.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 04, 2024 - 13:58 EST
This incident affected: Business Email.