The Premium Business Email (PBE) service issue has been fully resolved. We have been monitoring the platform and have not noticed any further issues. Our vendor continues to monitor it closely to ensure stability.
If you have any questions, please get in touch with our support team via live chat or by submitting a ticket.
Posted Sep 12, 2025 - 15:19 EDT
Monitoring
Our vendor has reported that the issue appears to be resolved, and services are functioning normally. They are continuing to monitor the platform closely to ensure its stability.
If you have any questions, please don’t hesitate to contact our support team via live chat or by submitting a ticket.
Posted Sep 12, 2025 - 09:42 EDT
Investigating
Our vendor has reported an issue affecting Premium Business Email webmail access and minor delays in email delivery. Their engineering team is actively investigating the issue and working to restore full functionality as quickly as possible.
If you have any questions, please don’t hesitate to contact our support team via live chat or by submitting a ticket.