Blacklisted IPs
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Jan 31, 2021 - 22:32 CST
Monitoring
Teams continue to work with the blacklisting party and are making good progress. Customers may continue to see impact to email delivery until the listing is removed. We are actively working toward this goal with critical priority.
Posted Jan 29, 2021 - 18:24 CST
Identified
Teams continue to work with the blacklisting party and are making good progress. Customers may continue to see impact to email delivery until the listing is removed. We are actively working toward this goal with critical priority.
Posted Jan 29, 2021 - 17:10 CST
Investigating
Teams are currently investigating a report of IP addresses showing on a less commonly used blacklist, and are working to resolve the issue. Some customers have experienced a delay in email delivery as a result. If you experience any issues, please feel free to reach out to our Support Team at 1.855.348.9060 or international at +1.517.322.0434.

We will continue to update this status as more information comes available.
Posted Jan 29, 2021 - 09:33 CST