Premium Business Email - Control Panel & Webmail Access Issues

Incident Report for Liquid Web - Services

Resolved

Our email vendor has confirmed that the issues affecting Premium Business Email – Control Panel and Webmail access have now been resolved.

We appreciate your patience while our team worked closely with the vendor to address this matter. If you have any further questions or concerns, please do not hesitate to reach out.
Posted Oct 30, 2025 - 04:38 EDT

Update

Our email vendor has confirmed that their engineers are actively working to resolve the issue.

We will continue to provide updates as more information becomes available.
Posted Oct 29, 2025 - 15:48 EDT

Update

The Premium Business Email portal login is now functioning as expected.

However, we are currently experiencing an outage with the Webmail interface. Our Email Vendor's team is fully engaged and working to resolve this as quickly as possible.

Email delivery and access through mail clients such as Outlook remain unaffected. At this time, only Webmail access is impacted.

We will continue to provide updates as more information becomes available.

If you have any questions, please don’t hesitate to contact our support team via LiveChat or Case.
Posted Oct 29, 2025 - 09:26 EDT

Investigating

We are currently experiencing issues with logging into the Premium Business Email Portals. We are working with our Email Provider to resolve this as quickly as possible.

Please note that email delivery has not been impacted. We will update this post with further information as it becomes available.

If you have any questions, please do not hesitate to contact a member of our support team via LiveChat or Case.
Posted Oct 28, 2025 - 22:19 EDT
This incident affected: Business Email.