Service disruption on multiple servers- DC3 Lansing

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Apr 07, 2026 - 15:57 EDT

Monitoring

We experienced an issue impacting a subset of servers within our Lansing data center. Initial investigation indicates the disruption was isolated to a specific section in our data center.

All affected parent servers and associated hosts have now been restored and are back online. Our team is continuing to investigate the root cause of this incident.

If you continue to experience any issues with your server, please contact our support team for assistance.

We appreciate your patience while we worked to resolve this matter.
Posted Apr 07, 2026 - 11:09 EDT

Investigating

We are currently investigating an issue affecting multiple servers in our Lansing data center(DC3).
We will provide updates as we learn more.

If you have any questions or concerns, please contact a member of our support team via live-chat or case (support@liquidweb.com).
Posted Apr 07, 2026 - 10:17 EDT
This incident affected: Data Centers (DC3 - LAN).