Yahoo Email Delivery issues
Incident Report for Liquid Web - Services
Resolved
Email functionality to Yahoo is stable and this incident has been resolved.
Posted Nov 01, 2024 - 06:50 EDT
Monitoring
Updates have been made on the Yahoo side to increase email deliverability. We will continue to monitor the situation.

Thank you for your understanding and patience. If you have any questions or need assistance, please reach out to our support team via live chat, support ticket, or by phone at (800)-580-4985, or internationally at (517)-322-0434.
Posted Oct 31, 2024 - 14:39 EDT
Investigating
We are currently experiencing an increase in customer reports regarding Yahoo’s blocking or deferring of emails sent from our Business Email mailboxes. Our team is actively collaborating with our email vendor to resolve this issue as quickly as possible.

At this time, there are no available workarounds. However, our email engineering team is fully engaged in addressing the problem, and we will keep you informed with any updates as they become available.

Thank you for your understanding and patience. If you have any questions or need assistance, please reach out to our support team via live chat, support ticket, or by phone at (800)-580-4985, or internationally at (517)-322-0434.
Posted Oct 30, 2024 - 18:10 EDT
This incident affected: Business Email.