Premium Business Email Login Issues
Incident Report for Liquid Web - Services
Resolved
A solution has been put in place by our email vendor. The issue of preventing access to the control panel has been resolved.

If you have any questions, don't hesitate to get in touch with a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 26, 2024 - 13:17 EDT
Update
We continue experiencing issues with Premium Business Admin Control Panel logins.
Our Email vendor is actively working to resolve the problem.
Please note that email delivery to Webmail is not impacted. We will share further updates as they become available.

We appreciate your patience in the matter, and if you have any questions, don't hesitate to get in touch with a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jul 26, 2024 - 10:05 EDT
Investigating
We are currently experiencing issues with logging into the Premium Business Email. We are working with our email vendor to resolve this as quickly as possible.

Please note that email delivery has not been affected.
Posted Jul 26, 2024 - 01:04 EDT
This incident affected: Business Email.