Premium Business Email, Webmail Login
Incident Report for Liquid Web - Services
Resolved
Our Email vendor has reported the issues affecting webmail login are now resolved. We have confirmed that we are able successfully access mailboxes using the webmail link: https://webmail.liquidweb.services/. If you have any additional questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 31, 2023 - 17:12 EDT
Update
Webmail login connections are impacted at this time, however direct SMTP connections using an email client such as Outlook, AppleMail, or Thunderbird are working. We will continue to provide updates as they become available. If you need assistance configuring your email client please don't hesitate to reach out to us via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 31, 2023 - 16:49 EDT
Investigating
We are seeing an increase in reports that the webmail URL for Liquid Web Premium Business Email https://webmail.liquidweb.services/ is malfunctioning.

The Liquid Web Support and Leadership teams are engaged. We have been in direct contact with our email vendor and their Engineering teams are looking into the issue.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted May 31, 2023 - 16:34 EDT
This incident affected: Business Email.