Email Blacklisting
Incident Report for Liquid Web - Services
Resolved
Our email vendor is reporting that this issue with remote blacklisting is resolved.

However, if any messages are found to be blacklisted by a remote service, please reach out to let us know. We will pass them on to our vendor for further review.
Posted Sep 07, 2021 - 15:47 CDT
Update
Our email vendor is still working on fully resolving the issue with remote blacklisting. They are seeing the delivery failures continue to decline or stabilize to more historical values.

If any messages are found to be blacklisted by a remote service, please reach out to let us know. We will pass them on to our vendor.

If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Aug 17, 2021 - 12:01 CDT
Update
After further reviewing with our Email Vendor, we were able to identify that this issue is currently only affecting Microsoft-based Email Platforms such as Hotmail.com, Outlook.com, Microsoft.com, Live.com, MSN.com.

We have seen a significant decrease in deliverability failures but were advised that attempting to resend messages from within the Business Email Webmail Interface will allow them to be successfully delivered.

As we have additional information we will update this post. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jun 17, 2021 - 14:28 CDT
Identified
We continue working with our email vendor to resolve an issue resulting in intermittent delivery failures when sending to external recipients.

While measures are being taken to prevent any impact to users, some may experience mail delivery delays or delivery failures. Impacted users are encouraged to retry their messages.

As we have additional information we will update this post. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Jun 07, 2021 - 13:20 CDT
This incident affected: Business Email.