Our Liquid Web Engineering team will be performing scheduled network maintenance on Saturday, February 28, from 1:00 AM – 7:00 AM EST to upgrade network hardware. This work is part of our ongoing efforts to improve redundancy, performance, and scalability across our network.
During this maintenance window, production servers and live websites will not be affected. However, customers who use IPMI (remote console access) during this time may experience brief latency or intermittent connectivity through the IPMI connection.
Our teams are here to help. Please do not hesitate to contact us via Chat or by opening a Case at my.liquidweb.com.
Internal ref: CC-13173
Posted Feb 18, 2026 - 15:43 EST
Scheduled
Our Liquid Web Engineering team will be performing scheduled network maintenance on Saturday, February 28, from 1:00 AM – 7:00 AM EST to upgrade network hardware. This work is part of our ongoing efforts to improve redundancy, performance, and scalability across our network.
During this maintenance window, production servers and live websites will not be affected. However, customers who use IPMI (remote console access) during this time may experience brief latency or intermittent connectivity through the IPMI connection.
Our teams are here to help. Please do not hesitate to contact us via Chat or by opening a Case at my.liquidweb.com.
Posted Feb 18, 2026 - 15:13 EST
This scheduled maintenance affects: Network (LAN Network).