Business Email Webmail Issues
Incident Report for Liquid Web - Services
Resolved
Our email vendor's engineering team has implemented a solution, and the issue has now been resolved!

We appreciate your patience while our team worked to resolve this matter. If you have any questions, please reach out to a member of our support team via live chat or ticket.
Posted Oct 22, 2024 - 01:15 EDT
Investigating
Our Email vendor is reporting issues with Webmail and we are working with them to resolve this issue. As we have additional info we will provide updates here.

Our teams are here to help you. Please do not hesitate to get help via live-chat, ticket or by toll-free phone at 1.855.348.9060 or internationally at +1.517.322.0434.
Posted Oct 21, 2024 - 17:20 EDT
This incident affected: Business Email.