Customer Portals & Cart Degraded

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Jun 15, 2022 - 13:22 EDT

Monitoring

Our teams have implemented a fix and we are monitoring the results.
Posted Jun 15, 2022 - 13:02 EDT

Investigating

We are currently investigating an issue affecting the my.liquidweb.com and manage.liquidweb.com portals. We will update this status page as soon as we have more information.

If you have any questions or concerns, please contact a member of our support team via live-chat, ticket (support@liquidweb.com), or by phone at 1-800-580-4985, 1-517-322-0434 (international).
Posted Jun 15, 2022 - 11:49 EDT