Storm Network Latency
Incident Report for Liquid Web - Services
Resolved
Network latency has returned to normal and has been stable for over two hours. The issue is considered resolved at this time.

As always, our support team is on standby if you need any help or have questions or concerns. You can connect with us through the following channels:

Live Chat: https://my.liquidweb.com/
Email: support@liquidweb.com
Phone: 1-800-580-4985 (US), 1-517-322-0434 (International)
Posted May 03, 2024 - 13:53 EDT
Monitoring
Our Network Engineering team has identified an issue that temporarily caused higher-than-normal latency for some of our Storm cloud products. The underlying cause has been addressed and performance is returning to normal. We will continue monitoring for changes.

Our support team is on standby if you need any help or have questions or concerns. You can connect with us through the following channels:

Live Chat: https://my.liquidweb.com/
Email: support@liquidweb.com
Phone: 1-800-580-4985 (US), 1-517-322-0434 (International)

We appreciate your understanding and patience as we work to provide you with a better service.
Thank you for your continued support.
Posted May 03, 2024 - 10:59 EDT
This incident affected: Network (LAN Network) and Cloud Dedicated, Cloud VPS Hosting.