Intermittent issues with internal phone system
Incident Report for Liquid Web - Services
Resolved
We have experienced no further issues with our phone system and the incident is now resolved.
Posted Aug 15, 2019 - 20:15 CDT
Monitoring
A fix has been implemented by our team and calls are now completing as expected. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Aug 15, 2019 - 19:22 CDT
Investigating
We are currently investigating an intermittent issue with our internal phone system. This is preventing some, but not all, of our employees from accepting phone calls. This may cause delays in receiving phone support, however chat and ticket support are not impacted.

If you have any questions, please contact a member of our support team via live-chat or ticket.
Posted Aug 15, 2019 - 18:17 CDT
This incident affected: Support Services (Phone Support).