Domain Registration Interruption

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Jan 04, 2026 - 14:57 EST

Monitoring

Enom has confirmed that their service issues are resolved, and our domain registration systems are back online. We have verified that transactions are processing correctly; however, we will continue to monitor the situation closely to ensure continued stability.
Posted Jan 04, 2026 - 13:12 EST

Investigating

We are aware of service interruptions affecting domain registrations due to an issue with our vendor, eNom. Our team is tracking the issue and will share updates here as they become available. We apologize for the inconvenience.
Posted Jan 04, 2026 - 11:52 EST