Premium Business Email Hosted Exchange Issues
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Mar 17, 2021 - 15:39 CDT
Investigating
Our Email vendor is reporting issues with IMAP Connectivity for Hosted Exchange Mailboxes and we are working with them to resolve this issue. As a workaround, impacted users are advised to use the Outlook Web Application (OWA) to access their mailbox. As we have additional info we will provide updates here.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 17, 2021 - 12:22 CDT
This incident affected: Business Email.