Payment Issues on liquidweb.com
Incident Report for Liquid Web - Services
Resolved
This incident has been resolved.
Posted Nov 05, 2020 - 22:45 EST
Investigating
We are currently investigating an issue with liquidweb.com not accepting or updating payment forms.

As more information becomes available we will update this status.

If you have any questions, please do not hesitate to contact a member of our support team via live-chat or by toll-free phone at 1.855.348.9060 or international at +1.517.322.0434.
Posted Nov 05, 2020 - 22:22 EST
This incident affected: Management Portal.