Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 19, 2023 - 21:00 EST
Scheduled
Our Email vendor will be performing a maintenance on their Hosted Email environment on Thursday, January 19th, 2023 at 07:00PM CST (01:00 AM GMT) and will last until 4:00AM CST (09:00 AM GMT). During this maintenance they will be upgrading code on upstream network equipment to provide stability enhancements to the email environment.
This maintenance encompasses Standard and Pro Mailboxes only (Not Exchange).
While all measures are being taken to prevent any impact to users, we do expect a brief, approximate 10 minute, disruption of email service during the maintenance window, likely occurring between 07:30PM and 08:30PM CST. In the event that a Hosted Email user experiences connectivity or access issues after the maintenance window, we encourage Administrators to contact a member of our support team via ticket, email to support@liquidweb.com, or by phone at 1-800-580-4985, 1-517-322-0434 (international) for further assistance.
Posted Jan 19, 2023 - 21:00 EST
This scheduled maintenance affected: Business Email.