Premium Business Email | Webmail Issues

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved, System is operating normally
Posted Jan 06, 2025 - 23:55 EST

Investigating

Our teams identified an issue affecting the Premium Business Email webmail login, and we are working with our email vendor to resolve the problem. We will provide updates here as more information becomes available.

If you have any questions, please contact a member of our support team via chat/ticket or by phone at +1-866-639-2377 (US) or +1-517-322-0434 (international).
Posted Jan 06, 2025 - 10:55 EST
This incident affected: Business Email.