Premium Business Email Delivery Delays
Incident Report for Liquid Web - Services
Resolved
This issue has been resolved.
Posted Mar 27, 2024 - 14:25 EDT
Monitoring
Our email vendor has let us know this issue should be resolved or only now affecting a small subset of users. Any users continuing to experience any slowness please send the normal email message headers over to our support team for further investigation on a case by case basis.

We will continue to monitor this situation.
Posted Mar 27, 2024 - 11:42 EDT
Update
Our Email Vendor is continuing their investigation of an issue that may be delaying incoming traffic to the Premium Business Email environment. Messages that are delayed will still be delivered and their engineers continue to be engaged.

Thank you for your patience while we work with them to resolve this issue. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 26, 2024 - 17:16 EDT
Identified
Our Email Vendor is aware of an issue that may be delaying incoming traffic to the Premium Business Email environment. Messages that are delayed will still be delivered and their engineers have been engaged.

Thank you for your patience while we work with them to resolve this issue. If you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Mar 26, 2024 - 08:49 EDT
This incident affected: Business Email.