Service Disruption Due to Network Switch Failure

Incident Report for Liquid Web - Services

Monitoring

The issue was caused by a failed network switch, which has now been replaced. Affected services are coming back online, and we are currently monitoring to ensure stability.

We appreciate your patience as our team worked to resolve this issue.

If you have any further questions or concerns, please feel free to reach out to us via live chat in your customer portal.
Posted Mar 24, 2026 - 14:09 EDT

Investigating

We are currently experiencing a service disruption affecting some servers due to a failed network switch. Our engineering team is actively working to resolve the issue as quickly as possible.

We appreciate your patience as our engineers work to restore full service. If you have any further questions or concerns, please contact us at support@liquidweb.com or via Live Chat.
Posted Mar 24, 2026 - 13:53 EDT