Networking issues DC4

Incident Report for Liquid Web - Services

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 12:58 EST

Update

We are continuing to monitor for any further issues.
Posted Nov 21, 2025 - 04:06 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 21, 2025 - 04:06 EST

Investigating

We are currently investigating a networking issue affecting the DC4 location. Our team is actively working on a resolution, and we will keep you updated on the status.
Posted Nov 21, 2025 - 02:12 EST
This incident affected: Data Centers (DC4 - PHX).