Premium Business Email - Login Issues
Incident Report for Liquid Web - Services
Resolved
Following extended monitoring without further disruption, this issue is considered resolved.
Posted Feb 20, 2023 - 05:32 EST
Monitoring
We have received notification that the issue has been fully resolved and are monitoring.
Posted Feb 18, 2023 - 20:38 EST
Identified
The Issue has been Identified and is being brought back online now. Will update you when all access has been fully restored.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 18, 2023 - 17:57 EST
Update
We are continuing to investigate this issue. You can check the rackspace status page for more information on the status of the Email services. https://status.apps.rackspace.com/index/viewincidents?group=100&start=1676696400
Posted Feb 18, 2023 - 13:59 EST
Investigating
Users of our Premium Business Email services are reporting issues with logging in at this time. Our teams are currently working to identify the root cause of this issue. As we have additional info we will provide updates here.

We appreciate your patience in the matter and if you have any questions, please contact a member of our support team via live-chat, ticket, or by phone at (800)-580-4985, (517)-322-0434 (international).
Posted Feb 18, 2023 - 13:52 EST
This incident affected: Business Email.