Acronis Cloud team has implemented a fix and resolved the issue. We are currently monitoring the results to ensure stability.
If you have any questions or concerns, please don't hesitate to contact us via Live Chat or by opening a case.
Posted Feb 24, 2026 - 02:09 EST
Update
Acronis Cloud team is actively working on the issue resolution and we will keep notifying you on the service status.
Posted Feb 23, 2026 - 22:45 EST
Identified
Acronis Cloud team is actively working on the issue resolution and we will keep notifying you on the service status.
Posted Feb 23, 2026 - 18:26 EST
Investigating
We would like to notify you that Acronis Cyber Protect Cloud in the USA (US5) data center is degraded. Acronis Cloud team is working on the issue resolution and will keep notifying you on the service status.
Service impact: Some customers might be unable to reach Acronis Web Restore, Acronis Cyber Protection Console and Management Console.